I have the problem that the backup stops all the time. I have the IOS app open, and usually it backups a couple dozen photos fine, then it backups another photo to 100% and stops. It doesn't continue on its own anymore. Restarting the backup or restarting the app makes it continue until it gets stuck again. It's a little bit annoying since I want to upload a large collection overnight. Running the TestFlight IOS app, and the latest self-hosted docker on a fresh install and fresh volumes. The Backup directory is on an external HDD, the host is the latest Ubuntu server. This behavior has been happening for many months no matter the server/iOS/app version.

Task List

Please complete the task list below. We need this information to help us reproduce the bug or point out problems in your setup. You are not providing enough info may delay our effort to help you.

  • [X ] I have read thoroughly the README setup and installation instructions.
  • [X ] I have included my docker-compose file.
  • [X ] I have included my redacted .env file.
  • [X ] I have included information on my machine, and environment.

To Reproduce Steps to reproduce the behavior:

  1. Start Backup
  2. Wait for .DNG file to get stuck

Screenshots immich-app Camera settings 1 Camera settings 2

System

  • IOS 16.0
  • Latest, fresh instance from last week
  • Latest from TestFlight

docker-compose.yml.txt env.txt

Example raw picture, I don't know if this specific one got stuck while uploading, but it is likely typical of the ones that get stuck https://upload.fritzcloud.eu/eNiTdA

Found a picture that got stuck, sadly can't share it here but the settings are: RAW, 12MP front camera 4032 x 3094, 31.9MB ISO 1000 Nothing different from my example picture from what I can see

0

I took about 50 raw photos to test and I haven't been able to reproduce the issue yet.

Can you let me know if you are accessing your instance locally or through a DNS/Reverse Proxy? Could it be anything in your network setting causing this issue?

0

I usually access through nginx-proxy-manager, just tried local access with the problem persisting. I am just wondering, once you upload, does the machine learning stuff kick in? Maybe my machine is getting overloaded and getting stuck? It's running on a 5 year old dualcore i7 laptop cpu which is not the fastest, but 16gb ram at least. I will check if I get any cpu overloading with glances.

0

@Sirtz My machine learning stuff kicked in. Let's try to disable the machine learning container and try upload again to see if it is the cause.

0

That did not help sadly.

Edit: Sorry, closed by accident

0

I think this happens on high server CPU load. Experimenting with that currently

0

@Sirtz what is the resource do you allocate for Immich? I can try replicate that on my end

0

I used to not put any resource limits, now for testing I put immich-server at 0.1 cpu:

services:
  immich-server:
    deploy:
      resources:
        limits:
          cpus: '0.1'

This makes almost every larger file backing up get stuck. So I think what happens is that when I run a gameserver or something and start an immich backup, once it spikes to 100% cpu the upload gets stuck.

0

Is this safe to assume that the issue is not with the app but with the requirement of the system?

Can you help provide the information of your server so we can document this case?

0

image

Not super powerful and I have quite a lot of services running. I hope you will be able to reproduce it, maybe try a high cpu load and then start backing up?

Edit: Man I misclick on the "close" button every time, sorry haha

0
© 2022 pullanswer.com - All rights reserved.