Compatibility Report

  • Name of the game with compatibility issues: ETHER VAPOR Remaster
  • Steam AppID of the game: 214570

System Information

  • Steam Deck 512 GB
  • Proton version: Experimental

I confirm:

  • [x] that I haven't found an existing compatibility report for this game.
  • [x] that I have checked whether there are updates for my system available.


Game has weird visual glitches on text and on bullets when shooting. Game is playable on deck with visual issues. download download (1) download (2) steam-214570.log


Start the game up and play through it, watch the text and bullets.


Hello @waspennator, fixme:d3dx:D3DXLoadSurfaceFromMemory Unhandled filter 0x3. looks like a possible line of interest from the log.


I tried the wined3d method too and it gives similar results, except certain text gets much darker, making it much harder to see


So theres actually two issues going on here. The first is that wines (protons) d3dx9_43.dll is causing the graphical glitches shown above. Which is a wine bug as it should ideally work the same as the windows version.

The second is that the game is acutally supposed to install DirectX (which includes the windows native version of the file above) as can be seen in the installscript.vdf. "%INSTALLDIR%\\redists\\DirectX\\DXSETUP.exe" The problem is that that isn't a thing included with the game so don't know why it tries to do that. Seems like a game issue unless i misunderstand something. The demo of the game includes d3dx9_43.dll in it's base folder and works fine without the graphical glitches.


I do see the install script message pop up when I was launching it on deck, but from what I've seen around, I dunno if it's a game issue or not. All the videos I see on yt running the game on windows look perfectly fine, no weird unreadable menu text or white squares when shooting

Very weird though that the demo is working fine but the full game isn't though.


I think any relatively modern windows version will already include these dll's with the OS without needing a install.

Edit: If you know how to use protontricks (or winetricks) you can probably get this working by installing d3dx9_43 through there.

Edit 2: ye just tried installing it through winetricks on my pc and it looks fine now. Also to be clear there is a proton issue here as it should work with the ones included same as windows. Tho the games install script also looks odd hehe.


Checking protondb, apparently this issues been happening for over 4 years (Game came out in 2012), text apparently didn't display at all on older versions of Proton along with the white square bug.

2 other things I noticed from there too is that sometimes boss models don't always render (haven't gotten to a boss consistently to test yet) and switching from full screen to windowed will rarely turn the screen black (Haven't tested on deck yet)

I'd assume proton/winetricks would fix it, I'm mostly just posting this here to see if it could be fixed without it.


Ye post everything you find. :+1:


Would it be needed to test DXVK on windows or not with this too BTW?

Also protondb page for reference.


Not if the issues don't show with native d3dx9_43 d3dx9 files is a wine thing not dxvk.

I will try to reproduce the other issues you mentioned. If i can even get to the boss that is hehe.


I got to the boss a few times but didn't notice anything.

Also tried switching between Fullscreen and windowed alot, but also nothing there. This was on KDE plasma Wayland and a R9 380


Gotcha, well for now, those are the only things I've stumbled across in general

© 2022 - All rights reserved.