• [X] I have tried with the latest version of Docker Desktop
  • [X] I have tried disabling enabled experimental features
  • [] I have uploaded Diagnostics
  • Diagnostics ID:

Expected behavior

Kubernetes is up and running

Actual behavior

Kubernetes failed to start

Information

  • macOS Version: 13.1
  • Intel chip or Apple chip: Apple
  • Docker Desktop Version: v4.16.2

Output of /Applications/Docker.app/Contents/MacOS/com.docker.diagnose check

Steps to reproduce the behavior

The issue has been found and solved by myself.

CAUSE

The cause of the issue is that coredns cannot pull the image because the path is wrong. Kubelet error: Failed to pull image "k8s.gcr.io/coredns:v1.9.3": rpc error: code = Unknown desc = Error response from daemon: failed to resolve reference "k8s.gcr.io/coredns:v1.9.3": k8s.gcr.io/coredns:v1.9.3: not found

SOLUTION [PATCH IS REQUIRED]

Right after update the image path on "k8s.gcr.io/coredns/coredns:v1.9.3" the service has been started.

So, please, add this fix to the next release,

0

hmmm...i wasn't able to reproduce this. When I enabled kubernetes and checked the pods, I saw it pull registry.k8s.io/coredns/coredns:v1.9.3. can you post your diagnostic id? https://docs.docker.com/desktop/troubleshoot/overview/#diagnose

0

I've already fixed this on my laptop. As I have some apps that are running on my machine (elasticsearch, prometheus, e.t.c.) I was not tend to reset my kube cluster. So, I found that the coredns pods in kube-system namespace cannot pull the image and cannot start. So, I've manually updated the deployment config for coredns and the problem has gone. I'm not sure that if I will revert those changes it give the proper diagnostic info because it will be syntetic test. And I will definitely not tend to uninstall the Docker Desktop and drop the all services in my kube. So, you decide if this make sense to check and fix.

0

Same Mac OS and Docker version, but with Intel Chip, after upgrade the kubernetes just won't start, had the kubernetes reseted several times, disabled und re-enabled several times, but didn't fix the problem.

0
© 2022 pullanswer.com - All rights reserved.