Describe the bug When I run Muse Hub, it says "Muse Hub Helper service is not running" I clicked connect button, but it's not connected I tried to start Muse Hub service manually, but it immediately shuts down. So I ran muse.service.exe manually via System Account, command prompt shows like this

I removed all musescores and, reinstalled this several times but that service doesn't run

Screenshots musehub_error musehub_error2

musehub_main

Platform information

  • OS: Windows 11 22H2 (10.0.22621.819)
  • MuseHub Version : 0.9.9.515 (Latest)
0

This problem is fixed just, by connecting USB My Windows' drive letter is not C, I think this caused the problem

0

Can you confirm that the A:\ProgramData\MuseHub folder exists? (and if anything is inside that folder).

Also, if you could please send over a screenshot of regedit with the path of Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders that would be great!

Thanks

0

Yes, A:\ProgramData/MuseHub exists It has Downloads, Log folder and Settings.json file In Download, .musedl, Installers, Instruments folder exist

Hub made ProgramData folder in C drive (USB) It has MuseSampler folder. (In musesampler folder, just .config file exists)

Here's regedit screenshot! musescore_error_1

0

MuseSampler folder in C drive is helpful, thanks!

Did hub not work at all when you first launched it (service disconnected), or did it stop working after you downloaded a library?

0

It's case of service disconnected (first launched it) If USB disconnected, Hub doesn't work properly and service can't be started

WOW6432Node side of above registry musescore_error_2

0

I see. Those screenshots look about right. Thanks!

It seems Hub is creating folders in the right location, but there might be an assumption about C drive existing within Hub (and at least with Sampler).

I'll let you know if I need any more information!

0
© 2022 pullanswer.com - All rights reserved.